How to enable SWING Seascape with Symantec Endpoint Protection (SEP)

This content has been created by Symantec support and engineering team.

Delay in Email to PDF conversion using SWING Software when SEP Lotus notes Auto protect is enabled. https://support.symantec.com/en_US/article.TECH235512.html

Situation

While using SWING Seascape or PDF Converter for Notes to convert email into PDF IBM Notes 9.0.1 Social Edition there is a delay for email conversion when SEP Lotus notes plug-in is enabled. With SEP Lotus notes plug-in disabled, the email is converted instantly to a PDF. With SEP plug-in enabled, it takes around 10 minute to convert the email to PDF. This converter is installed as a plug-in on Lotus notes .

Environment

Windows 7 and Windows 10 with IBM Notes 9.0.1 Social Edition

Cause

When a sample document is opened using SWING Seascape, each time SEP intercepts and extracts all the files to temp folder "C:\Users\Symantec\AppData\Local\Temp\LDVPScan\". It includes SWING Seascape files also. There may be images, JAR files, DLL, JS files and so on.

When a JAR file is given to the scanner, decomposer decompresses all the files and scanner scans each file. This behavior is by design.

Solution

A. For managed SEP clients:

  1. Edit the "Virus and Spyware protection policy

  2. Under Windows Settings > Email scans > Lotus Notes Auto-Protect > Scan details Tab

  3. Select the option to "Scan only selected extensions"

  4. Once you click on "Select extensions" button, ensure that JAR is not added in the file extensions list (by default not added)

B. For unmanaged SEP clients:

  1. Open SEP GUI > Change Settings tab

  2. Click on "Configure settings" button under Virus and Spyware Protection section

  3. Click on Notes Auto-Protect Tab

  4. Choose the option "Selected" under File Types.

  5. Ensure that JAR is not added in the file extensions list

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