How to enable SWING PDF Converter with Symantec Endpoint Protection (SEP)
This content has been created by Symantec support and engineering team.
Delay in Email to PDF conversion using SWING Software when SEP Lotus notes Auto protect is enabled. https://support.symantec.com/en_US/article.TECH235512.html
Situation
While using SWING PDF Converter to convert email into PDF IBM Notes 9.0.1 Social Edition there is a delay for email conversion when SEP Lotus notes plug-in is enabled. With SEP Lotus notes plug-in disabled, the email is converted instantly to a PDF. With SEP plug-in enabled, it takes around 10 minute to convert the email to PDF. This converter is installed as a plug-in on Lotus notes .
Environment
Windows 7 and Windows 10 with IBM Notes 9.0.1 Social Edition
Cause
When a sample document is opened using SWING PDF Converter, each time SEP intercepts and extracts all the files to temp folder "C:\Users\Symantec\AppData\Local\Temp\LDVPScan\". It includes SWING PDF Converter files also. There may be images, JAR files, DLL, JS files and so on.
When a JAR file is given to the scanner, decomposer decompresses all the files and scanner scans each file. This behavior is by design.
Solution
A. For managed SEP clients:
Edit the "Virus and Spyware protection policy
Under Windows Settings > Email scans > Lotus Notes Auto-Protect > Scan details Tab
Select the option to "Scan only selected extensions"
Once you click on "Select extensions" button, ensure that JAR is not added in the file extensions list (by default not added)
B. For unmanaged SEP clients:
Open SEP GUI > Change Settings tab
Click on "Configure settings" button under Virus and Spyware Protection section
Click on Notes Auto-Protect Tab
Choose the option "Selected" under File Types.
Ensure that JAR is not added in the file extensions list
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